DNS issues for Group10.tcplusondemand.com
Incident Report for TimeClock Plus
Resolved
This incident has been resolved.
Posted May 20, 2020 - 16:53 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2020 - 16:15 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2020 - 15:54 CDT
This incident affected: Application Health (Group10.tcplusondemand.com).