Client Internet Service Provider Issues
Incident Report for TimeClock Plus
Resolved
Comcast-xfinity services appear to have been restored at this time.
Posted Oct 30, 2019 - 06:31 CDT
Identified
At this time the scope of impact appears to be limited to customers using Comcast-xFinity internet services. This ISP's availability can be monitored more directly here: https://istheservicedown.com/problems/comcast-xfinity
Posted Oct 29, 2019 - 15:00 CDT
Investigating
Instances of intermittent connectivity issues have been reported from various customers and at this time all signs point toward regional ISP network connectivity problems. We are working to identify which ISPs are at fault and will continue to track this event to resolution.

We encourage customers to work with their internal IT staff and administration to identify plans of action if you are experiencing such issues. If you have any questions or concerns related to this event, please don't hesitate to reach out to our Support team at https://timeclockplus.force.com/TCPSupport/s/.
Posted Oct 29, 2019 - 14:52 CDT