CloudOps 7.1.13.2 OnDemand Updates Cancelation
Incident Report for TCP Software
Resolved
The incident that led to the cancellation of last weeks updates has been fully resolved.

7.1.13.3 v7 OnDemand updates have been completed for the following server stacks:

prod02.tcplusondemand.com
prod03.tcplusondemand.com
prod10.tcplusondemand.com
prod11.tcplusondemand.com
prod12.tcplusondemand.com
prod14.tcplusondemand.com
prod15.tcplusondemand.com
prod18.tcplusondemand.com
prod23.tcplusondemand.com
prod25.tcplusondemand.com (updated to 7.1.13.4)
prod26.tcplusondemand.com
prod31.tcplusondemand.com
prod32.tcplusondemand.com
​​​​​​​prod34.tcplusondemand.com
​​​​​​​prod35.tcplusondemand.com

We thank you for your continued patience and support as we worked to resolve this incident over the last week.
Posted Jul 29, 2021 - 23:29 CDT
Update
v7 OnDemand updates to 7.1.13.3 for the CloudOps Small Server Stacks are scheduled for Thursday, July 29th between 9:00 PM CST - 3:00 AM CST.

While the updates are taking place, you may experience intermittent access to your v7 OnDemand website, which includes the following applications: Manager, WebClock, TelClock and TCP Smartphone apps. If you have purchased 200 or 400 Series Remote Data Terminals or Hand scanners, they will continue to operate seamlessly in fallback mode.

Although we don’t expect the software updates to take the entire time allotted and only some customers will experience a disruption in service, we apologize in advance for any inconvenience this may cause. Normal operations will resume upon completion of the updates.

If you have any questions or concerns, please feel free to contact TCP technical support at 325-223-9300, or email us at SaaS.Tickets@TCPSoftware.com and make sure to stay informed about future maintenance and update events with our Status Page: https://status.tcplusondemand.com/
Posted Jul 28, 2021 - 16:24 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2021 - 05:55 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 26, 2021 - 11:58 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 23, 2021 - 17:11 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2021 - 12:03 CDT
Investigating
TCP made the decision to cancel last night's v7 OnDemand updates as a precaution due to an issue identified during pre-deployment quality checks.

We tentatively expect to deploy 7.1.13.2 updates to the small server stack groups next Thursday, July 29th. A follow up email will be sent early next week to confirm the date and time of the updates.

We will be working diligently to identify and troubleshoot the issue as quickly as possible.

We appreciate your patience and support and look forward to delivering the next revision of TCP soon.
Posted Jul 23, 2021 - 07:12 CDT
This incident affected: TimeClock Plus Time and Attendance (Prod02.tcplusondemand.com, Prod10.tcplusondemand.com, Prod11.tcplusondemand.com, Prod12.tcplusondemand.com, Prod14.tcplusondemand.com, Prod15.tcplusondemand.com, Prod18.tcplusondemand.com, Prod23.tcplusondemand.com, Prod25.tcplusondemand.com, Prod26.tcplusondemand.com, Prod31.tcplusondemand.com, Prod32.tcplusondemand.com, Prod34.tcplusondemand.com, Prod35.tcplusondemand.com).