Increased Error Rate
Incident Report for TimeClock Plus
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 08:36 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2020 - 12:56 CDT
Investigating
We are currently investigating this issue.
Posted Mar 13, 2020 - 11:58 CDT
This incident affected: Application Health (Prod13.tcplusondemand.com).